HDU1754 I hate it(线段树 单点修改)

时间:2022-08-05 15:46:56

好久没打线段树,来一道练练手,但说句实话,I really hate it!!!!

 

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。 
这让很多学生很反感。 

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。


Input本题目包含多组测试,请处理到文件结束。 

在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。 
学生ID编号分别从1编到N。 
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。 
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。 
Output对于每一次询问操作,在一行里面输出最高成绩。Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9

Hint

Huge input,the C function scanf() will work better than cin

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 200010
#define lson root<<1
#define rson root<<1|1
using namespace std; int node[N<<]; void pushup(int root)
{
node[root]=max(node[lson],node[rson]);
} void build(int l,int r,int root)
{
if(l==r)
{
scanf("%d",&node[root]);
return;
}
int mid=(l+r)>>;
build(l,mid,lson);
build(mid+,r,rson);
pushup(root);
} void update(int a,int b,int l,int r,int root)
{
if(l==r)
{
node[root]=b;
return;
}
int mid=(l+r)>>;
if(a<=mid)
{
update(a,b,l,mid,lson);
}
else
{
update(a,b,mid+,r,rson);
}
pushup(root);
} int query(int a,int b,int l,int r,int root)
{
if(a<=l&&b>=r)
{
return node[root];
}
int mid=(l+r)>>;
int ans=;
if(a<=mid)
{
ans=max(ans,query(a,b,l,mid,lson));
}
if(b>mid)
{
ans=max(ans,query(a,b,mid+,r,rson));
}
return ans;
} int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
build(,n,);
while(m--)
{
char c;
int a,b;
scanf(" %c %d%d",&c,&a,&b);
if(c=='Q')
{
int ans=query(a,b,,n,);
printf("%d\n",ans);
}
else
{
update(a,b,,n,);
}
}
}
return ;
}

 

 

每天刷题,身体棒棒!