【PTA 天梯赛训练】电话聊天狂人(简单map)

时间:2023-05-02 12:49:01

输入格式:

输入首先给出正整数N(≤10^5),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3
#include<bits/stdc++.h>
using namespace std;
int main()
{
    ,sum=;                     //sum并列狂人的人数
    cin>>n;
    map<string,int>ma;
    map<string,int>::iterator it;
    string a,b,num;
    ;i<n;i++)
    {
        cin>>a>>b;
        ma[a]++,ma[b]++;
        if(ma[a]>maxx||ma[a]==maxx&&a<num)    //通话次数最多 或 通话次数最大且号码小
        {
            maxx=ma[a];
            num=a;
        }
        if(ma[b]>maxx||ma[b]==maxx&&b<num)
        {
            maxx=ma[b];
            num=b;
        }
    }
    for(it=ma.begin();it!=ma.end();it++)
        if(it->second==maxx)
            sum++;
    )
    cout<<num<<" "<<maxx<<endl;
    else cout<<num<<" "<<maxx<<" "<<sum<<endl;
    ;
}