HDU 2489 Minimal Ratio Tree (dfs+Prim最小生成树)

时间:2021-12-07 18:43:36

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2489

Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.





HDU 2489 Minimal Ratio Tree (dfs+Prim最小生成树)




Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line
contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all
0, since there is no edge connecting a node with itself.





All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].



The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree. 

HDU 2489 Minimal Ratio Tree (dfs+Prim最小生成树)

 
Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie,
look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
 
Sample Input
3 2
30 20 10
0 6 2
6 0 3
2 3 0
2 2
1 1
0 2
2 0
0 0
 
Sample Output
1 3
1 2
 
Source

题意:

给出n个点。要从中选出m个点。要求选出的这m个点的全部边的边权值/点权值要最小!

并要输出所选的这m个点,假设有多种选择方法,那么就输出第一个点小的方案,假设第一个点同样就输出第二个点小的,一次类推!

PS:

因为这题的n比較小,仅仅有15。所以能够先dfs枚举出所选择的点。然后在用最小生成树Prim算出最小的边权值的和。

代码例如以下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
#define INF 1e18;
const double eps = 1e-9;
const int maxn = 17;
int n, m;
int e_val[maxn][maxn];
int node[maxn];
int ansn[maxn];//记录终于选得是哪些点
int tt[maxn];//记录中间过程选得是哪些点
int vis[maxn];
int low[maxn];
double minn;
int Prim(int s)
{
int sum=0;
memset(vis,0,sizeof(vis));
for(int i = 1; i <= m; i++)
{
low[tt[i]] = e_val[s][tt[i]];
}
vis[s] = 1;
low[s] = 0;
int pos = s;
for(int i = 1; i < m; i++)
{
int min_t = INF;
for(int j = 1; j <= m; j++)
{
if(!vis[tt[j]] && min_t > low[tt[j]])
{
min_t = low[tt[j]];
pos = tt[j];
}
}
vis[pos] = 1;
sum += min_t;
for(int j = 1; j <= m; j++)
{
if(!vis[tt[j]] && e_val[pos][tt[j]] < low[tt[j]])
low[tt[j]]=e_val[pos][tt[j]];
}
}
return sum;
}
void DFS(int n_pre, int k)
{
if(k == m)
{
double n_sum = 0;
for(int i = 1; i <= m ; i++)
{
n_sum+=node[tt[i]];
}
double e_ans = 0;
e_ans = Prim(tt[1]);
double ans = e_ans/(n_sum*1.0);
//if(ans < minn)
if(ans - minn < -(eps))
{
minn = ans;
for(int i = 1; i <= m; i++)
{
ansn[i] = tt[i];
}
}
return ;
}
for(int i = n_pre+1; i <= n; i++)
{
tt[k+1] = i;
DFS(i,k+1);
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(n==0 && m==0)
break;
minn = INF;
for(int i = 1; i <= n; i++)
{
scanf("%d",&node[i]);
}
for(int i = 1; i <= n; i++)
{
for(int j = 1; j <= n; j++)
{
scanf("%d",&e_val[i][j]);
}
}
for(int i = 1; i <= n; i++)
{
tt[1] = i;
DFS(i, 1);
}
for(int i = 1; i < m; i++)
{
printf("%d ",ansn[i]);
}
printf("%d\n",ansn[m]);
}
return 0;
}

HDU 2489 Minimal Ratio Tree (dfs+Prim最小生成树)的更多相关文章

  1. HDU 2489 Minimal Ratio Tree &lpar;DFS枚举&plus;最小生成树Prim&rpar;

    Minimal Ratio Tree Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) ...

  2. HDU 2489 Minimal Ratio Tree&lpar;dfs枚举&plus;最小生成树&rpar;

    想到枚举m个点,然后求最小生成树,ratio即为最小生成树的边权/总的点权.但是怎么枚举这m个点,实在不会.网上查了一下大牛们的解法,用dfs枚举,没想到dfs还有这么个作用. 参考链接:http:/ ...

  3. HDU 2489 Minimal Ratio Tree(prim&plus;DFS)

    Minimal Ratio Tree Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Other ...

  4. HDU 2489 Minimal Ratio Tree(暴力&plus;最小生成树)(2008 Asia Regional Beijing)

    Description For a tree, which nodes and edges are all weighted, the ratio of it is calculated accord ...

  5. HDU 2489 Minimal Ratio Tree 最小生成树&plus;DFS

    Minimal Ratio Tree Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Other ...

  6. hdu 2489 Minimal Ratio Tree

    http://acm.hdu.edu.cn/showproblem.php?pid=2489 这道题就是n个点中选择m个点形成一个生成树使得生成树的ratio最小.暴力枚举+最小生成树. #inclu ...

  7. hdu2489 Minimal Ratio Tree dfs枚举组合情况&plus;最小生成树

    #include <stdio.h> #include <set> #include <string.h> #include <algorithm> u ...

  8. HDU2489 Minimal Ratio Tree 【DFS】&plus;【最小生成树Prim】

    Minimal Ratio Tree Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Other ...

  9. Minimal Ratio Tree HDU - 2489

    Minimal Ratio Tree HDU - 2489 暴力枚举点,然后跑最小生成树得到这些点时的最小边权之和. 由于枚举的时候本来就是按照字典序的,不需要额外判. 错误原因:要求输出的结尾不能有 ...

随机推荐

  1. S3C6410移植apache和php

    需要准备的东西: Apache-1.3.39 for linux Php-4.4.8 for linux Ubuntu amd64位 PC机 6410开发板,我用的是友善之臂 交叉编译: 交叉编译呢, ...

  2. js的关联数组

    我自己感觉js是不支持关联数组的,只有索引数组.想要实现js关联数组的效果,就使用js的对象,使用键值对.如果对数组动态处理用push函数,取值用pop函数.此外,对数组操作有几个比较好的函数,joi ...

  3. 水题 Codeforces Round &num;300 A Cutting Banner

    题目传送门 /* 水题:一开始看错题意,以为是任意切割,DFS来做:结果只是在中间切出一段来 判断是否余下的是 "CODEFORCES" :) */ #include <cs ...

  4. struts2——通配符

    struts2的配置文件是 struts.xml.. 在这个配置文件里面可以使用通配符..其中的好处就是,大大减少了配置文件的内容..当然,相应付出的代价是可读性.. 使用通配符的原则是 约定高于配置 ...

  5. Masonry 布局 cell 高度适应的一种方案&lpar;实现类似朋友圈简单布局&rpar;

    来源:伯乐在线 - 夏天然后 链接:http://ios.jobbole.com/89298/ 点击 → 申请加入伯乐在线专栏作者 前言: 我模仿的是微博的布局所以也就没有 评论动态刷新cell. 1 ...

  6. 使用python爬取P站图片

    刚开学时有一段时间周末没事,于是经常在P站的特辑里收图,但是P站加载图片的速度比较感人,觉得自己身为计算机专业,怎么可以做一张张图慢慢下这么low的事,而且这样效率的确也太低了,于是就想写个程序来帮我 ...

  7. HttpWebResponse类

    HttpWebResponse类的作用用于在客户端获取返回的响应的信息,还记得HttpResponse类吗?你是否在写B/S程序的时候,经常用到Response.Write()呢? HttpRespo ...

  8. &lbrack;学习笔记&rsqb;jQuery实现一些动画效果的方法

    jQuery实现效果的方法 1,隐藏和显示:hide(),show(),toggle()  // [ˈtɑ:gl]切换 语法: $(selector).hide(speed,callback); $( ...

  9. 对Java配置文件Properties的读取、写入与更新操作

    http://breezylee.iteye.com/blog/1340868 对Java配置文件Properties的读取.写入与更新操作 博客分类: javase properties  对Jav ...

  10. input长度随输入内容动态变化 input光标定位在最右侧

    <input type="text" onkeydown="this.onkeyup();" onkeyup="this.size=(this. ...