PAT 1017 Queueing at Bank (模拟)

时间:2022-07-05 04:03:26

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a
window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the
processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题目有一个坑点,那就是只要下午5

点之前到的顾客,5点之后也必须要服务,即使已经下班了,意思都没说清楚

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <map>
#include <string>
#include <strstream>
#include <vector>
#include <queue> using namespace std;
typedef long long int LL;
int n;
int k;
struct Node
{
int st;
int t;
}a[10005],tag[105];
int cmp(Node a,Node b)
{
return a.st<b.st;
}
queue<Node> q;
int tim(int hh,int mm,int ss){return hh*60*60+mm*60+ss;}
int hh,mm,ss,t;
int ans[10005];
int main()
{
scanf("%d%d",&n,&k);
for(int i=1;i<=n;i++)
{
scanf("%d:%d:%d %d",&hh,&mm,&ss,&t);
a[i].st=tim(hh,mm,ss);
a[i].t=t*60;
}
sort(a+1,a+n+1,cmp); int ss=tim(8,0,0);
int ee=tim(17,0,0);
for(int i=1;i<=k;i++)
{tag[i].st=0;tag[i].t=0;}
int cnt=1;
int ans=0;
int num=0;
for(int i=1;i<=n;i++)
{
if(a[i].st<ss)
{
ans+=(ss-a[i].st);
a[i].st=ss;
}
else
break;
} for(int i=ss;i;i++)
{
if(i>ee&&q.empty())
break;
if(i==ss)
{
int p;
for(p=1;p<=n;p++)
{
if(a[p].st==i)
{
q.push(a[p]);
}
else
break;
}
cnt=p;
}
else
{
if(i<=ee&&cnt<=n&&a[cnt].st==i)
q.push(a[cnt++]);
}
for(int j=1;j<=k;j++)
{ if(tag[j].st!=0&&tag[j].st+tag[j].t==i)
{
tag[j].st=0;
if(!q.empty())
{
tag[j].st=i;
tag[j].t=q.front().t;
ans+=i-q.front().st;
num++;
q.pop();
}
}
else if(tag[j].st==0)
{
if(!q.empty())
{
tag[j].st=i;
tag[j].t=q.front().t;
ans+=i-q.front().st;
num++;
q.pop();
}
} }
} if(num==0)
{ printf("%0.0\n");
}
else
printf("%.1f\n",ans/60.0/num);
return 0;
}