HDU1005 数列找规律

时间:2023-03-09 21:21:08
HDU1005  数列找规律

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).


Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3 1 2 10 0 0 0

Sample Output
2 5

#include<stdio.h>
#include<string.h>
int main()
{
int a,b,n;
while(scanf("%d%d%d",&a,&b,&n)==3)//scanf返回赋值成功的个数
{
if(!a&&!b&&!n)
break;
int arr[48];
arr[1]=1;
arr[2]=1;
for(int i=3;i<48;i++)
arr[i]=((a*arr[i-1]+b*arr[i-2])%7);
printf("%d\n",arr[n%48]);
}
return 0;
}