hdu1081 To The Max 2016-09-11 10:06 29人阅读 评论(0) 收藏

时间:2023-03-09 20:48:35
hdu1081 To The Max                                                                                            2016-09-11 10:06             29人阅读              评论(0)              收藏

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11685    Accepted Submission(s): 5649

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.



As an example, the maximal sub-rectangle of the array:



0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2



is in the lower left corner:



9 2

-4 1

-1 8



and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines).
These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
这道题的意思是给一个矩阵,求助最大子矩阵和,很容易联想到一维的最大字段和,所以我们可以把二维的转化为一维的
用上一个辅助数组 s[i][j]表示从第一行到底i行,第j列的所有元素的和,那个第i行到第k行第j列的和就为s[k][j]-s[i-1][j];
用for循环遍历即可转化为一维的情况
下面是ac代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <stack>
#include <queue>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f int a[105][105];
int n;
int s[105][105];//j列1行i行的和
int b[105][105];//第i行到j行暂时保存这些行的情况 int main()
{
while(~scanf("%d",&n))
{
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
scanf("%d",&a[i][j]);
memset(s,0,sizeof(s));
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
s[i][j]=s[i-1][j]+a[i][j];
int mx=-1280000;
memset (b,0,sizeof(b));
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
for(int k=j; k<=n; k++)
{
if(b[j][k]<0)
b[j][k]=s[k][i]-s[j-1][i];
else
b[j][k]+=s[k][i]-s[j-1][i];
if(mx<b[j][k])
mx=b[j][k];
}
}
printf("%d\n",mx); } return 0;
}